Impaired access to HelpDesk application

Incident Report for HelpDesk

Resolved

This incident has been mitigated. HelpDesk services are back fully operational
Posted Jul 22, 2021 - 19:15 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 22, 2021 - 18:44 CEST

Monitoring

Service is back operational, we will actively monitor the issue.
Posted Jul 22, 2021 - 18:44 CEST

Identified

The issue has been identified as an outage of one of our sub-processors responsible for our CDNs, Akamai.

Our Admins are working on bringing back the full functionality of our services as soon as possible
Posted Jul 22, 2021 - 18:11 CEST

Investigating

We are currently investigating the issue
Posted Jul 22, 2021 - 17:50 CEST
This incident affected: Agent app and Support chat on www.helpdesk.com.