HelpDesk unavailability
Incident Report for HelpDesk
Resolved
This incident has been resolved
Posted Aug 12, 2021 - 22:00 CEST
Monitoring
The issue has been resolved, we'll continue monitoring the situation
Posted Aug 12, 2021 - 21:32 CEST
Investigating
We are currently investigating this issue.
Posted Aug 12, 2021 - 18:34 CEST
This incident affected: Agent app, API, Integrations, Support chat on www.helpdesk.com, and Subprocessors' service.