Resolved
This incident has been mitigated. HelpDesk services are back fully operational
Monitoring
We are continuing to monitor for any further issues.
Monitoring
Service is back operational, we will actively monitor the issue.
Identified
The issue has been identified as an outage of one of our sub-processors responsible for our CDNs, Akamai.
Our Admins are working on bringing back the full functionality of our services as soon as possible
Investigating
We are currently investigating the issue