HelpDesk

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
HelpDesk unavailability
Resolved·Full outage

This incident has been resolved

Thu, Aug 12, 2021, 08:00 PM
(5 years ago)
·
Affected components
Aug 12, 2021, 04:34 PM
07:32 PM
Agent app
API
Integrations
Support chat on www.helpdesk.com
Subprocessors' service
Updates

Resolved

This incident has been resolved

Thu, Aug 12, 2021, 08:00 PM

Monitoring

The issue has been resolved, we'll continue monitoring the situation

Thu, Aug 12, 2021, 07:32 PM(27 minutes earlier)

Investigating

We are currently investigating this issue.

Thu, Aug 12, 2021, 04:34 PM(2 hours earlier)